Рубрика: 1C

Получить путь программы, файлов в 1С Предприятие 8.3

КаталогПрограммы() — доступ на чтение Пример возврата: C:\Program Files (x86)\1cv8\8.3.17.1851\bin\ КаталогВременныхФайлов() — доступ на чтение и запись Пример возврата: C:\Users\User\AppData\Local\Temp\

Читать далее

Base64 кодировать и декодировать в 1С Предприятие 8.3

Пример функций: &НаСервере Функция Base64_Encode(СтрокаДляКодирования) Возврат Base64Строка(ПолучитьДвоичныеДанныеИзСтроки(СтрокаДляКодирования)); КонецФункции &НаСервере Функция Base64_Decode(СтрокаДляКодирования) Возврат ПолучитьСтрокуИзДвоичныхДанных(Base64Значение(СтрокаДляКодирования)); КонецФункции  

Читать далее

СведенияОВнешнейОбработке для обработчика в 1С Предприятие 8.3

Сведения о внешней обработке Чтобы подключить внешний отчет или обработку в справочник Дополнительные отчеты и обработки необходимо описать экспортную функцию

Читать далее

Поле выбора группы или элемента справочника в 1С Предприятие 8.3

Для выбора только группы у элемента поля создать событие НачалоВыбора и задать: &НаКлиенте Процедура ГруппаВидаНоменклатурыНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка) СтандартнаяОбработка = Ложь;

Читать далее

FileExists, проверка на существование файла на диске в 1С Предприятие 8.3

Пример функции проверки: Функция ПроверитьСуществованиеФайла(ПутьКФайлу) Экспорт ФайлНаДиске = Новый Файл(ПутьКФайлу); Если ФайлНаДиске.Существует() Тогда Возврат Истина; КонецЕсли; Возврат Ложь; КонецФункции  

Читать далее

Фильтровать форму выбора из поля заполнения в 1С Предприятие 8.3

К примеру на изображение представлен скрин на котором есть поле «Договор контрагента», которое должно при выборе выводить список договоров от

Читать далее

Изменить номер заказа при добавлении в 1С Предприятие 8.3 УТ 11.4

В примере находится последний заказ не зависимо от даты и организации и увеличивается номер на 1: &НаСервере Процедура БМ_ПередЗаписьюНаСервереПосле(Отказ, ТекущийОбъект,

Читать далее