Рубрика: 1C

Функция транслит для 1С Предприятие 8.3

Пример функции: Функция Транслит(Вход) Экспорт Коды = Новый Соответствие; Коды.Вставить(«0″,»0»); Коды.Вставить(«1″,»1»); Коды.Вставить(«2″,»2»); Коды.Вставить(«3″,»3»); Коды.Вставить(«4″,»4»); Коды.Вставить(«5″,»5»); Коды.Вставить(«6″,»6»); Коды.Вставить(«7″,»7»); Коды.Вставить(«8″,»8»); Коды.Вставить(«9″,»9»); Коды.Вставить(«

Читать далее

Получить список всех родителей элемента справочника

Пример скрипта: Номенклатура = Справочники.Номенклатура.НайтиПоКоду(«0004324234»); Список = Новый СписокЗначений; Родитель = Номенклатура.Родитель; Пока ЗначениеЗаполнено(Родитель) Цикл Сообщить(Родитель); Список.Добавить(Родитель); Родитель = Родитель.Родитель;

Читать далее

Вызвать исключение в 1С Предприятие 8.3

Вызвать остановку выполнения скрипта Если Параметры.Свойство(«АвтоТест») Тогда // Возврат при получении формы для анализа. Возврат; КонецЕсли; Если НЕ Пользователи.ЭтоПолноправныйПользователь(, Истина)

Читать далее

Получить путь программы, файлов в 1С Предприятие 8.3

КаталогПрограммы() — доступ на чтение Пример возврата: C:\Program Files (x86)\1cv8\8.3.17.1851\bin\ КаталогВременныхФайлов() — доступ на чтение и запись Пример возврата: C:\Users\User\AppData\Local\Temp\

Читать далее

Base64 кодировать и декодировать в 1С Предприятие 8.3

Пример функций: &НаСервере Функция Base64_Encode(СтрокаДляКодирования) Возврат Base64Строка(ПолучитьДвоичныеДанныеИзСтроки(СтрокаДляКодирования)); КонецФункции &НаСервере Функция Base64_Decode(СтрокаДляКодирования) Возврат ПолучитьСтрокуИзДвоичныхДанных(Base64Значение(СтрокаДляКодирования)); КонецФункции  

Читать далее

СведенияОВнешнейОбработке для обработчика в 1С Предприятие 8.3

Сведения о внешней обработке Чтобы подключить внешний отчет или обработку в справочник Дополнительные отчеты и обработки необходимо описать экспортную функцию

Читать далее

Поле выбора группы или элемента справочника в 1С Предприятие 8.3

Для выбора только группы у элемента поля создать событие НачалоВыбора и задать: &НаКлиенте Процедура ГруппаВидаНоменклатурыНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка) СтандартнаяОбработка = Ложь;

Читать далее

FileExists, проверка на существование файла на диске в 1С Предприятие 8.3

Пример функции проверки: Функция ПроверитьСуществованиеФайла(ПутьКФайлу) Экспорт ФайлНаДиске = Новый Файл(ПутьКФайлу); Если ФайлНаДиске.Существует() Тогда Возврат Истина; КонецЕсли; Возврат Ложь; КонецФункции  

Читать далее